Services not live updating
Incident Report for Planning Center
Resolved
We have identified and repaired the problem. Sorry for the inconvenience. If you had trouble with Services LIVE, please refresh the page and try again.
Posted about 1 month ago. Dec 16, 2018 - 06:17 PST
Investigating
We are investigating an issue with Services and Services LIVE not updating in real-time when things change.
Posted about 1 month ago. Dec 16, 2018 - 06:06 PST
This incident affected: Services.