Emails delayed for Registrations
Incident Report for Planning Center
Resolved
Email delivery for Registrations is all caught up! We identified and fixed the cause of the delay.
Posted about 1 year ago. Jan 29, 2018 - 14:01 PST
Investigating
Email delivery is delayed for Registrations. We are investigating.
Posted about 1 year ago. Jan 29, 2018 - 13:15 PST