Elevated Response Times
Incident Report for Planning Center
Resolved
Giving is back at full speed but we'll continue to monitor performance this week. This morning's slowdown did impact both sides of Giving (admin & donor).
Posted 10 days ago. Aug 12, 2019 - 10:28 PDT
Monitoring
We're monitoring a fix for the slow loading times and are monitoring now. This issue was isolated to the admin side of Giving (no donor-facing impact).
Posted 10 days ago. Aug 12, 2019 - 09:33 PDT
Investigating
Giving is loading very slowly or not at all for many customers. Our team is investigating.
Posted 10 days ago. Aug 12, 2019 - 09:23 PDT
This incident affected: Giving.