Errors Collecting Payments Through Stripe
Incident Report for Planning Center
Postmortem

At 11:32 AM Pacific Time, during the course of conducting some system maintenance, we inadvertently caused an issue that began disconnecting customers' Stripe accounts from their Planning Center accounts. Without a Stripe account, it's impossible to collect payments in Planning Center Registrations or donations in Planning Center Giving.

The problem was detected and stopped immediately, but only after it had affected a small subset of customers. We immediately began the process of gathering data from our point in time backups to restore those accounts to full functionality.

Our teams are investigating ways in which we can prevent these kinds of incidents from happening in the future.

We’re incredibly sorry for the downtime.

If you have any questions, please contact our support team by emailing support@planning.center.

Posted 9 days ago. Mar 12, 2019 - 15:29 PDT

Resolved
All functionality has been restored. A full incident report is forthcoming, along with an email with additional information to the administrators of affected churches.

We're incredibly sorry for the downtime.
Posted 9 days ago. Mar 12, 2019 - 14:31 PDT
Monitoring
A fix has been implemented and we're currently monitoring the results. Payment processing and all things related to Stripe should now be working properly in Giving and Registrations.
Posted 9 days ago. Mar 12, 2019 - 13:53 PDT
Identified
The Stripe integration of affected churches is currently broken, which affects the ability to collect payments and generate Stripe payout reports.
Our operations team is currently working on restoring the affected Stripe connections.
Posted 9 days ago. Mar 12, 2019 - 12:21 PDT
Investigating
A small subset of our churches are currently unable to collect payments via Giving or Registrations. We're investigating now.
Posted 9 days ago. Mar 12, 2019 - 11:59 PDT
This incident affected: Giving and Registrations.