Application Delays
Incident Report for Planning Center
Resolved
All of our tasks are caught up.
Posted 12 days ago. Sep 04, 2019 - 12:54 PDT
Monitoring
A cause has been identified and a fix is in place. Delays are now shortening.
Posted 12 days ago. Sep 04, 2019 - 11:45 PDT
Investigating
Some tasks in Planning Center People, such as generating reports, sending emails, or importing CSV files, are experiencing significant delays. Our team is working to address the situation.
Posted 12 days ago. Sep 04, 2019 - 11:15 PDT
This incident affected: People.