List Refreshes Paused
Incident Report for Planning Center
Resolved
Refreshing lists has been reenabled.
Posted 6 months ago. May 16, 2018 - 07:25 PDT
Identified
We've temporarily disabled refreshing lists while we investigate a technical problem.
Posted 6 months ago. May 16, 2018 - 07:16 PDT
This incident affected: People.