Elevated Response Times
Incident Report for Planning Center
Resolved
Error rates and response times are back to normal.
Posted Jun 28, 2016 - 08:39 PDT
Identified
We've identified the problem and are working to resolve it.
Posted Jun 28, 2016 - 08:23 PDT
Investigating
We're experiencing increased response times and are currently looking into the issue.
Posted Jun 28, 2016 - 08:17 PDT