Planning Center People Trouble Loading CSS
Incident Report for Planning Center
Resolved
Everything is back to normal (except better than before!)
Posted 10 months ago. Jan 16, 2018 - 16:08 PST
Investigating
Planning Center People has a very "unique" look at the moment. We're on it.
Posted 10 months ago. Jan 16, 2018 - 16:06 PST