Delays sending emails and processing CSV imports
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted 9 months ago. Feb 14, 2018 - 15:22 PST
Identified
We're aware of delays in performing some tasks such as sending emails and importing CSV files.
Posted 9 months ago. Feb 14, 2018 - 13:59 PST