Payments failing in Registrations
Incident Report for Planning Center
Resolved
The issue with accepting payments has been fixed in Registrations.
Posted Nov 16, 2016 - 07:13 PST
Identified
We are aware of an issue accepting payments in Registrations. We are working on a fix now.
Posted Nov 16, 2016 - 07:01 PST