Elevated Response Times
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted 21 days ago. Nov 18, 2018 - 08:21 PST
Monitoring
Services response times have returned to normal. We're continuing to monitor the results!
Posted 21 days ago. Nov 18, 2018 - 07:59 PST
Investigating
Planning Center Services is experiencing increased response times and we are currently looking into the issue.
Posted 21 days ago. Nov 18, 2018 - 07:08 PST
This incident affected: Services.