Connectivity Issues
Incident Report for Planning Center
Resolved
Looks like Cox has fixed their connectivity issue.
Posted Mar 14, 2017 - 19:55 PDT
Identified
California and Arizona residents with Cox may be unable to access to Planning Center. We will provide updates as soon as we have more information.
Posted Mar 14, 2017 - 16:37 PDT