Elevated Response Times
Incident Report for Planning Center
Resolved
This incident has been resolved!
Posted 12 months ago. Nov 30, 2017 - 13:33 PST
Identified
The issue has been identified and a fix is being implemented.
Posted 12 months ago. Nov 30, 2017 - 10:46 PST
Investigating
We're experiencing increased response times in Planning Center Resources and are currently looking into the issue.
Posted 12 months ago. Nov 30, 2017 - 09:25 PST