Phone and email responses may be delayed
Incident Report for Planning Center
Resolved
Our help desk software is back up and running! Email responses should be back to normal now.
Posted Aug 26, 2016 - 12:08 PDT
Identified
Our help desk software is running slow. All phone and email responses may be delayed, we will respond to all requests as soon as possible!
Posted Aug 26, 2016 - 10:03 PDT